summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBryce Harrington <bryce@osg.samsung.com>2015-04-15 15:31:11 -0700
committerBryce Harrington <bryce@osg.samsung.com>2015-05-21 15:05:48 -0700
commited2c644892824b70869783f768b53a1dbb3c06aa (patch)
treea8dc1f8413e2ec0eec718782339836fed1c4834d /Makefile.am
parent273c285fa6a97db3753e87b4fd75f718b1855226 (diff)
downloadweston-ed2c644892824b70869783f768b53a1dbb3c06aa.tar.gz
tests: Support --config to enable tests to override config defaults
Implements a simple mechanism to allow tests to customize the configuration. For a given <name>-test.c just place a <name>.ini file at the same location as the test itself. Alternately, you can generate a <name>.ini in the same directory that the compiled test is placed (i.e. the top builddir). If no configuration file is found, then no configuration will be used (i.e. --no-config is specified.) Signed-off-by: Bryce Harrington <bryce@osg.samsung.com> Reviewed-By: Derek Foreman <derekf@osg.samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2f16fac4..543c7369 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -967,7 +967,8 @@ ivi_tests =
$(ivi_tests) : $(builddir)/tests/weston-ivi.ini
AM_TESTS_ENVIRONMENT = \
- abs_builddir='$(abs_builddir)'; export abs_builddir;
+ abs_builddir='$(abs_builddir)'; export abs_builddir; \
+ abs_top_srcdir='$(abs_top_srcdir)'; export abs_top_srcdir;
TEST_EXTENSIONS = .la .weston
LA_LOG_COMPILER = $(srcdir)/tests/weston-tests-env