summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDerek Foreman <derekf@osg.samsung.com>2015-06-29 14:05:38 -0500
committerDerek Foreman <derekf@osg.samsung.com>2015-10-21 16:40:08 -0500
commite2926942775616252dc6be12b8d2142f6e8b0ea8 (patch)
treee453257ab05ce06e17c8b2f66540b3863f6dfda3 /Makefile.am
parent33598ffe8d692f21eb49cb41afa60226e132a21c (diff)
downloadweston-e2926942775616252dc6be12b8d2142f6e8b0ea8.tar.gz
build: Add -lrt for programs that use clock_gettime()
glibc requires this prior to 2.17, and we already do it in a few other places. Signed-off-by: Derek Foreman <derekf@osg.samsung.com> Reviewed-by: Giulio Camuffo <giuliocamuffo@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 13c43bf9..55e3bcb4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -65,7 +65,7 @@ weston_LDFLAGS = -export-dynamic
weston_CPPFLAGS = $(AM_CPPFLAGS) -DIN_WESTON
weston_CFLAGS = $(AM_CFLAGS) $(COMPOSITOR_CFLAGS) $(LIBUNWIND_CFLAGS)
weston_LDADD = $(COMPOSITOR_LIBS) $(LIBUNWIND_LIBS) \
- $(DLOPEN_LIBS) -lm libshared.la
+ $(DLOPEN_LIBS) -lm -lrt libshared.la
weston_SOURCES = \
src/git-version.h \
@@ -506,7 +506,7 @@ nodist_weston_presentation_shm_SOURCES = \
protocol/presentation_timing-protocol.c \
protocol/presentation_timing-client-protocol.h
weston_presentation_shm_CFLAGS = $(AM_CFLAGS) $(SIMPLE_CLIENT_CFLAGS)
-weston_presentation_shm_LDADD = $(SIMPLE_CLIENT_LIBS) libshared.la -lm
+weston_presentation_shm_LDADD = $(SIMPLE_CLIENT_LIBS) libshared.la -lm -lrt
weston_multi_resource_SOURCES = clients/multi-resource.c
weston_multi_resource_CFLAGS = $(AM_CFLAGS) $(SIMPLE_CLIENT_CFLAGS)