summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenoit Gschwind <gschwind@gnu-log.net>2016-04-15 20:28:31 -0700
committerBryce Harrington <bryce@osg.samsung.com>2016-05-03 01:24:28 -0700
commite16acabf7a54e0e0c3c4f000726de487d4583035 (patch)
treecb04778ed7dc8f953c86c85fd2e05bce3b364560 /Makefile.am
parent2da6d0cf699bcb62cc39136d4422ebea4b1220e9 (diff)
downloadweston-e16acabf7a54e0e0c3c4f000726de487d4583035.tar.gz
x11: port the x11 backend to the new init api
Use a "well" defined structure to configure x11-backend and move configuration file parsing inside the weston compositor code. Enforce destruction of all backend config objects after initialization. Since the backend config struct versioning implies that there we expect potential future descrepancy between main's definition of the config object and the backend's, don't allow the backend to hang onto the config object outside the initialization scope. Signed-off-by: Bryce Harrington <bryce@osg.samsung.com> Reviewed-by: Giulio Camuffo <giuliocamuffo@gmail.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Benoit Gschwind <gschwind@gnu-log.net> Tested-by: Benoit Gschwind <gschwind@gnu-log.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f94eae26..810945bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,6 +75,7 @@ weston_SOURCES = \
src/compositor-headless.h \
src/compositor-fbdev.h \
src/compositor-rdp.h \
+ src/compositor-x11.h \
src/input.c \
src/data-device.c \
src/screenshooter.c \
@@ -214,6 +215,7 @@ westoninclude_HEADERS = \
src/compositor-headless.h \
src/compositor-fbdev.h \
src/compositor-rdp.h \
+ src/compositor-x11.h \
src/timeline-object.h \
shared/matrix.h \
shared/config-parser.h \
@@ -256,6 +258,7 @@ x11_backend_la_CFLAGS = \
$(AM_CFLAGS)
x11_backend_la_SOURCES = \
src/compositor-x11.c \
+ src/compositor-x11.h \
shared/helpers.h
endif