summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenoit Gschwind <gschwind@gnu-log.net>2016-04-22 17:05:26 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-04-25 16:36:44 +0300
commitbd57310c11bd32a5f07c3d9aae998b0bb8b84c00 (patch)
treeb26f155c8989f77238002702068aa5db5c33970e /Makefile.am
parent2dd10e0c60fbf4bd403fd9fa6c67d20c2ba0ee09 (diff)
downloadweston-bd57310c11bd32a5f07c3d9aae998b0bb8b84c00.tar.gz
compositor-rdp: refactor configuration API
Implement a "well" defined API to configure the rdp backend. Following according to discution about libweston API. Signed-off-by: Benoit Gschwind <gschwind@gnu-log.net> Reviewed-by: David FORT <rdp.effort@gmail.com> [Pekka: added missing headers to Makefile.am] Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 41f07891..2d727307 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,6 +73,7 @@ weston_SOURCES = \
src/compositor.c \
src/compositor.h \
src/compositor-headless.h \
+ src/compositor-rdp.h \
src/input.c \
src/data-device.c \
src/screenshooter.c \
@@ -210,6 +211,7 @@ westoninclude_HEADERS = \
src/version.h \
src/compositor.h \
src/compositor-headless.h \
+ src/compositor-rdp.h \
src/timeline-object.h \
shared/matrix.h \
shared/config-parser.h \
@@ -393,6 +395,7 @@ rdp_backend_la_CFLAGS = \
$(AM_CFLAGS)
rdp_backend_la_SOURCES = \
src/compositor-rdp.c \
+ src/compositor-rdp.h \
shared/helpers.h
endif