summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@bitplanet.net>2014-01-27 21:56:12 -0800
committerKristian Høgsberg <krh@bitplanet.net>2014-02-01 00:07:21 -0800
commitbc00dbe4f5c044efef3359b3418bf0417c3669b2 (patch)
tree23ed8f9e0c2361cb9ee32382275e3e661780a01a /Makefile.am
parente895f148e64396b01a325dca9724c0c900d9fb77 (diff)
downloadweston-bc00dbe4f5c044efef3359b3418bf0417c3669b2.tar.gz
build: Move desktop-shell/Makefile.am into toplevel Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am45
1 files changed, 43 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 82e21c4d..f95c4506 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,12 +3,14 @@ xwayland_subdir = xwayland
endif
bin_PROGRAMS =
+moduledir = $(libdir)/weston
+module_LTLIBRARIES =
+BUILT_SOURCES =
SUBDIRS = \
shared \
src \
$(xwayland_subdir) \
- desktop-shell \
clients \
protocol \
tests \
@@ -27,7 +29,7 @@ weston.ini : $(srcdir)/weston.ini.in
all-local : weston.ini
-CLEANFILES = weston.ini
+CLEANFILES = weston.ini $(BUILT_SOURCES)
westondatadir = $(datadir)/weston
@@ -54,3 +56,42 @@ wcap_decode_SOURCES = \
wcap_decode_CFLAGS = $(GCC_CFLAGS) $(WCAP_CFLAGS)
wcap_decode_LDADD = $(WCAP_LIBS)
endif
+
+
+if ENABLE_DESKTOP_SHELL
+
+module_LTLIBRARIES += desktop-shell.la
+
+desktop_shell_la_CPPFLAGS = \
+ -I$(top_srcdir)/shared \
+ -I$(top_srcdir)/src \
+ -I$(top_builddir)/src \
+ -I$(top_builddir)/desktop-shell \
+ -DDATADIR='"$(datadir)"' \
+ -DMODULEDIR='"$(moduledir)"' \
+ -DLIBEXECDIR='"$(libexecdir)"' \
+ -DIN_WESTON
+
+desktop_shell_la_LDFLAGS = -module -avoid-version
+desktop_shell_la_LIBADD = $(COMPOSITOR_LIBS) \
+ shared/libshared.la
+desktop_shell_la_CFLAGS = $(GCC_CFLAGS) $(COMPOSITOR_CFLAGS)
+desktop_shell_la_SOURCES = \
+ desktop-shell/shell.h \
+ desktop-shell/shell.c \
+ desktop-shell/exposay.c \
+ desktop-shell/input-panel.c \
+ desktop-shell/desktop-shell-protocol.c \
+ desktop-shell/desktop-shell-server-protocol.h \
+ desktop-shell/xdg-shell-protocol.c \
+ desktop-shell/xdg-shell-server-protocol.h
+
+BUILT_SOURCES += \
+ desktop-shell/desktop-shell-protocol.c \
+ desktop-shell/desktop-shell-server-protocol.h \
+ desktop-shell/xdg-shell-protocol.c \
+ desktop-shell/xdg-shell-server-protocol.h
+endif
+
+wayland_protocoldir = $(top_srcdir)/protocol
+include $(top_srcdir)/wayland-scanner.mk