summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.co.uk>2014-12-17 16:20:43 +0200
committerBryce Harrington <bryce@osg.samsung.com>2015-01-20 17:13:33 -0800
commitb77acf592fdc625a09e4d1ea1672dba2db128238 (patch)
treec363c90e8690b381d84ed82c7103c07dc3163d78 /Makefile.am
parent63495864d35aeb790c3bb175d0e46b3d75bfe4f6 (diff)
downloadweston-b77acf592fdc625a09e4d1ea1672dba2db128238.tar.gz
simple-egl: HACK to report presentation flags
So that we can test the per-surface ZERO_COPY flag: - start Weston on DRM backend - run ./weston-simple-egl -o (need to be opaque to end up on overlay) - hit debug key 'V' to enable the (broken) hw overlays The debug key is used by first hitting Mod+Shift+space, then hitting 'v'. Enabling overlays should change the flags from 0x7 to 0xe. To verify the window is really on an overlay, use debug key 'S' to tint all GL-composited things green. This patch is not intended for upstream. Reviewed-by: Mario Kleiner <mario.kleiner.de@gmail.com> Tested-by: Mario Kleiner <mario.kleiner.de@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3a37be05..7d0914ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -441,6 +441,8 @@ if BUILD_SIMPLE_EGL_CLIENTS
demo_clients += weston-simple-egl
weston_simple_egl_SOURCES = clients/simple-egl.c
nodist_weston_simple_egl_SOURCES = \
+ protocol/presentation_timing-protocol.c \
+ protocol/presentation_timing-client-protocol.h \
protocol/xdg-shell-protocol.c \
protocol/xdg-shell-client-protocol.h \
protocol/ivi-application-protocol.c \