summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexandros Frantzis <alexandros.frantzis@collabora.com>2018-10-25 17:32:36 +0300
committerAlexandros Frantzis <alexandros.frantzis@collabora.com>2018-12-18 17:25:09 +0200
commitb10066842680c996f45295b3b1130e7b08735a7f (patch)
treec2b75714cbe7d40da3224c52948cd475cdf00170 /Makefile.am
parenta0d9cc64f66f5d2e7a70db4624bcdc52e67cedfc (diff)
downloadweston-b10066842680c996f45295b3b1130e7b08735a7f.tar.gz
clients: Add simple-dmabuf-egl
Add a client that uses EGL/GLESv2 to draw to dmabuf buffers, utilizing EGLImages and FBOs. The client uses GBM to create the dmabufs buffers. The simple-dmabuf-egl client is partly based on patch [1] that changes dmabuf clients to use GBM instead of libdrm code, but has been greatly simplified since in this case we don't require direct pixel access or non-RGBA formats. [1] https://patchwork.freedesktop.org/patch/239796/ Signed-off-by: Alexandros Frantzis <alexandros.frantzis@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c2fea50..1493f697 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -680,6 +680,20 @@ weston_simple_dmabuf_v4l_CFLAGS = $(AM_CFLAGS) $(SIMPLE_DMABUF_V4L_CLIENT_CFLAGS
weston_simple_dmabuf_v4l_LDADD = $(SIMPLE_DMABUF_V4L_CLIENT_LIBS) libshared.la
endif
+if BUILD_SIMPLE_DMABUF_EGL_CLIENT
+demo_clients += weston-simple-dmabuf-egl
+weston_simple_dmabuf_egl_SOURCES = clients/simple-dmabuf-egl.c
+nodist_weston_simple_dmabuf_egl_SOURCES = \
+ protocol/xdg-shell-unstable-v6-protocol.c \
+ protocol/xdg-shell-unstable-v6-client-protocol.h \
+ protocol/fullscreen-shell-unstable-v1-protocol.c \
+ protocol/fullscreen-shell-unstable-v1-client-protocol.h \
+ protocol/linux-dmabuf-unstable-v1-protocol.c \
+ protocol/linux-dmabuf-unstable-v1-client-protocol.h
+weston_simple_dmabuf_egl_CFLAGS = $(AM_CFLAGS) $(SIMPLE_DMABUF_EGL_CLIENT_CFLAGS)
+weston_simple_dmabuf_egl_LDADD = $(SIMPLE_DMABUF_EGL_CLIENT_LIBS) libshared.la
+endif
+
noinst_LTLIBRARIES += libtoytoolkit.la
libtoytoolkit_la_SOURCES = \