summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-02-18 16:53:27 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-03-07 13:29:27 +0200
commitb00c79b587a4903df576008a64a49f851fed234c (patch)
treea88bf6fd903de24ed4e4cfb23f8464f6c4e176be /Makefile.am
parent16d1fa156abd296a69afed0df8588b7d33d6cb0d (diff)
downloadweston-b00c79b587a4903df576008a64a49f851fed234c.tar.gz
protocol: migrate to stable presentation-time.xml
Remove the unstable presentation_timing.xml file, and use presentation-time.xml from wayland-protocols instead to generate all the Presentation extension bindings. The following renames are done according to the XML changes: - generated header includes - enum constants and macros prefixed with WP_ - interface symbol names prefixed with wp_ - protocol API calls prefixed with wp_ Clients use wp_presentation_interface.name rather than hardcoding the global interface name: presentation-shm, weston-info, presentation-test. Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Bryce Harrington <bryce@osg.samsung.com> Reviewed-by: Jonas Ã…dahl <jadahl@gmail.com> [Pekka: updated wayland-protocols dependency to 1.2]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 10 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 505d40a9..fe08d949 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -121,8 +121,8 @@ nodist_weston_SOURCES = \
protocol/text-input-unstable-v1-server-protocol.h \
protocol/input-method-unstable-v1-protocol.c \
protocol/input-method-unstable-v1-server-protocol.h \
- protocol/presentation_timing-protocol.c \
- protocol/presentation_timing-server-protocol.h \
+ protocol/presentation-time-protocol.c \
+ protocol/presentation-time-server-protocol.h \
protocol/scaler-protocol.c \
protocol/scaler-server-protocol.h \
protocol/linux-dmabuf-unstable-v1-protocol.c \
@@ -501,8 +501,8 @@ weston_presentation_shm_SOURCES = \
clients/presentation-shm.c \
shared/helpers.h
nodist_weston_presentation_shm_SOURCES = \
- protocol/presentation_timing-protocol.c \
- protocol/presentation_timing-client-protocol.h
+ protocol/presentation-time-protocol.c \
+ protocol/presentation-time-client-protocol.h
weston_presentation_shm_CFLAGS = $(AM_CFLAGS) $(SIMPLE_CLIENT_CFLAGS)
weston_presentation_shm_LDADD = $(SIMPLE_CLIENT_LIBS) libshared.la -lm -lrt
@@ -721,8 +721,8 @@ weston_info_SOURCES = \
clients/weston-info.c \
shared/helpers.h
nodist_weston_info_SOURCES = \
- protocol/presentation_timing-protocol.c \
- protocol/presentation_timing-client-protocol.h
+ protocol/presentation-time-protocol.c \
+ protocol/presentation-time-client-protocol.h
weston_info_LDADD = $(WESTON_INFO_LIBS) libshared.la
weston_info_CFLAGS = $(AM_CFLAGS) $(CLIENT_CFLAGS)
@@ -770,8 +770,8 @@ BUILT_SOURCES += \
protocol/weston-desktop-shell-protocol.c \
protocol/scaler-client-protocol.h \
protocol/scaler-protocol.c \
- protocol/presentation_timing-protocol.c \
- protocol/presentation_timing-client-protocol.h \
+ protocol/presentation-time-protocol.c \
+ protocol/presentation-time-client-protocol.h \
protocol/fullscreen-shell-unstable-v1-protocol.c \
protocol/fullscreen-shell-unstable-v1-client-protocol.h \
protocol/xdg-shell-unstable-v5-protocol.c \
@@ -1234,8 +1234,8 @@ presentation_weston_SOURCES = \
tests/presentation-test.c \
shared/helpers.h
nodist_presentation_weston_SOURCES = \
- protocol/presentation_timing-protocol.c \
- protocol/presentation_timing-client-protocol.h
+ protocol/presentation-time-protocol.c \
+ protocol/presentation-time-client-protocol.h
presentation_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
presentation_weston_LDADD = libtest-client.la
@@ -1353,7 +1353,6 @@ EXTRA_DIST += \
protocol/weston-screenshooter.xml \
protocol/text-cursor-position.xml \
protocol/weston-test.xml \
- protocol/presentation_timing.xml \
protocol/scaler.xml \
protocol/ivi-application.xml \
protocol/ivi-hmi-controller.xml