summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-04-05 14:08:11 +0300
committerBryce Harrington <bryce@osg.samsung.com>2016-04-13 17:28:14 -0700
commitaff703ec2b4165e87bc57816869afe5666c325d1 (patch)
tree1482bc86cf47bf49563df878b5f69e4c63622404 /Makefile.am
parent7b3a52ab39bfa95b461460ef1cc1ac81824e00f7 (diff)
downloadweston-aff703ec2b4165e87bc57816869afe5666c325d1.tar.gz
Makefile: fix systemd-notify plugin CFLAGS
SYSTEMD_DAEMON_LIBS does not belong in CFLAGS, but SYSTEMD_DAEMON_CFLAGS does. Fix that. Add the missing COMPOSITOR_CFLAGS. Otherwise compiling the plugin will use the system wayland-server.h when it should be using the one pointed to by pkg-config. The latter fixes the build for me, as my system libwayland-server is older than what Weston and this plugin require, and the correct version is only found in my install $prefix. Cc: Egor Starkov <egor.starkov@ge.com> Cc: Eugen Friedrich <efriedrich@de.adit-jv.com> Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d1644ac5..9bed32c7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,7 +102,8 @@ module_LTLIBRARIES += systemd-notify.la
systemd_notify_la_LDFLAGS = -module -avoid-version
systemd_notify_la_LIBADD = $(SYSTEMD_DAEMON_LIBS)
systemd_notify_la_CFLAGS = \
- $(SYSTEMD_DAEMON_LIBS) \
+ $(COMPOSITOR_CFLAGS) \
+ $(SYSTEMD_DAEMON_CFLAGS) \
$(PIXMAN_CFLAGS) \
$(AM_CFLAGS)
systemd_notify_la_SOURCES = \