summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorUcan, Emre \(ADITG/SW1\) <eucan@de.adit-jv.com>2015-10-15 14:51:43 +0000
committerBryce Harrington <bryce@osg.samsung.com>2015-10-15 16:14:00 -0700
commitae2541d3f2923cfb300a42ab333906bea350ce91 (patch)
treee26f8f93300741847e5db211cacf6e74d603fe8e /Makefile.am
parentc7ee7608ef0dabc93efc2f68b7aca57a45be1a2d (diff)
downloadweston-ae2541d3f2923cfb300a42ab333906bea350ce91.tar.gz
ivi-shell: install ivi-layout-export.h
IVI-Shell is designed to be used with other controller modules than hmi-controller.These controller modules require the ivi-layout-export header file to properly integrate with the ivi-shell. The header file should be installed when ivi-shell is enabled, because these controller modules are not a part of the weston repository. Signed-off-by: Emre Ucan <eucan@de.adit-jv.com> Reviewed-by: Bryce Harrington <bryce@osg.samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 19003909..13c43bf9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -215,6 +215,11 @@ westoninclude_HEADERS = \
shared/zalloc.h \
shared/platform.h
+if ENABLE_IVI_SHELL
+westoninclude_HEADERS += \
+ ivi-shell/ivi-layout-export.h
+endif
+
if ENABLE_EGL
module_LTLIBRARIES += gl-renderer.la
gl_renderer_la_LDFLAGS = -module -avoid-version