summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenoit Gschwind <gschwind@gnu-log.net>2016-04-27 23:56:42 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-04-29 14:15:01 +0300
commit934e89a749b77e8294113f75ad7f8b3fe3150bc8 (patch)
tree2ae68bece9864fbdb87f2128167ace6d13dbddf1 /Makefile.am
parente5b5659240e1c1c23bf74c0b126de982747dffa7 (diff)
downloadweston-934e89a749b77e8294113f75ad7f8b3fe3150bc8.tar.gz
fbdev-backend: refactor configuration API
Implement a "well" defined API to configure the fbdev backend. Following and according to discussion about libweston API The output transform configuration is moved into weston and added to the fbdev configuration structure. Signed-off-by: Benoit Gschwind <gschwind@gnu-log.net> [Pekka: squashed two patches and rebased.] Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 2d727307..f94eae26 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,7 +72,8 @@ weston_SOURCES = \
src/log.c \
src/compositor.c \
src/compositor.h \
- src/compositor-headless.h \
+ src/compositor-headless.h \
+ src/compositor-fbdev.h \
src/compositor-rdp.h \
src/input.c \
src/data-device.c \
@@ -211,6 +212,7 @@ westoninclude_HEADERS = \
src/version.h \
src/compositor.h \
src/compositor-headless.h \
+ src/compositor-fbdev.h \
src/compositor-rdp.h \
src/timeline-object.h \
shared/matrix.h \
@@ -379,6 +381,7 @@ fbdev_backend_la_CFLAGS = \
$(AM_CFLAGS)
fbdev_backend_la_SOURCES = \
src/compositor-fbdev.c \
+ src/compositor-fbdev.h \
shared/helpers.h \
$(INPUT_BACKEND_SOURCES)
endif