summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBryce Harrington <bryce@osg.samsung.com>2015-09-24 14:31:44 -0700
committerBryce Harrington <bryce@osg.samsung.com>2015-09-25 11:23:08 -0700
commit892122ed64cebb1955253ed098563b8dc5c9c899 (patch)
treef64e6a819d62c700030655914998d8d93466a40b /Makefile.am
parent89dcea9b58fa7f2fcda3108c024d699be8a334e3 (diff)
downloadweston-892122ed64cebb1955253ed098563b8dc5c9c899.tar.gz
tests: Migrate screenshot code from internal test to client helpers
These routines provide test cases an ability to capture screen images for rendering verification. This commit is a no-change refactoring, except for making the routines non-static. Makefile rules are also updated; most notably, this links test clients against the cairo libraries now. v2: Fix pointer code styling, suggested in review Signed-off-by: Bryce Harrington <bryce@osg.samsung.com> Acked-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Derek Foreman <derekf@osg.samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d66cc04..b82b8eeb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1153,8 +1153,8 @@ libtest_client_la_SOURCES = \
nodist_libtest_client_la_SOURCES = \
protocol/weston-test-protocol.c \
protocol/weston-test-client-protocol.h
-libtest_client_la_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
-libtest_client_la_LIBADD = $(TEST_CLIENT_LIBS) libshared.la libtest-runner.la
+libtest_client_la_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS) $(CAIRO_CFLAGS)
+libtest_client_la_LIBADD = $(TEST_CLIENT_LIBS) $(CAIRO_LIBS) libshared.la libtest-runner.la
#
@@ -1162,8 +1162,8 @@ libtest_client_la_LIBADD = $(TEST_CLIENT_LIBS) libshared.la libtest-runner.la
#
internal_screenshot_weston_SOURCES = tests/internal-screenshot-test.c
-internal_screenshot_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS) $(CAIRO_CFLAGS)
-internal_screenshot_weston_LDADD = libtest-client.la $(CAIRO_LIBS)
+internal_screenshot_weston_CFLAGS = $(AM_CFLAGS) $(TEST_CLIENT_CFLAGS)
+internal_screenshot_weston_LDADD = libtest-client.la
#