summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNobuhiko Tanibata <NOBUHIKO_TANIBATA@xddp.denso.co.jp>2014-11-27 13:22:00 +0900
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2014-12-04 17:13:41 +0200
commit6f9df656e0e982d0515fcd15ab422c83a6e51f91 (patch)
treed534880ce58b79fbbaa947c60276530ec1922a1f /Makefile.am
parentbff1b4a5964e5c9b92a88b82160407138eca35b7 (diff)
downloadweston-6f9df656e0e982d0515fcd15ab422c83a6e51f91.tar.gz
ivi-shell: add IVI layout APIs
- ivi-layout.so - introduces ivi-layout-export.h, ivi-layout.[ch] API set of controlling properties of surface and layer which groups surfaces. An unique ID whose type is integer is required to create surface and layer. With the unique ID, surface and layer are identified to control them. The API set consists of APIs to control properties of surface and layers about followings, - visibility. - opacity. - clipping (x,y,width,height). - position and size of it to be displayed. - orientation per 90 degree. - add or remove surfaces to a layer. - order of surfaces/layers in layer/screen to be displayed. - commit to apply property changes. - notifications of property change. Signed-off-by: Nobuhiko Tanibata <NOBUHIKO_TANIBATA@xddp.denso.co.jp> Acked-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 22d0af9c..0f6df8aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -722,6 +722,24 @@ nodist_fullscreen_shell_la_SOURCES = \
BUILT_SOURCES += $(nodist_fullscreen_shell_la_SOURCES)
endif
+if ENABLE_IVI_SHELL
+
+module_LTLIBRARIES += \
+ $(ivi_layout)
+
+ivi_layout = ivi-layout.la
+ivi_layout_la_LDFLAGS = -module -avoid-version
+ivi_layout_la_LIBADD = $(COMPOSITOR_LIBS) libshared.la
+ivi_layout_la_CFLAGS = $(GCC_CFLAGS) $(COMPOSITOR_CFLAGS)
+ivi_layout_la_SOURCES = \
+ ivi-shell/ivi-layout-export.h \
+ ivi-shell/ivi-layout-private.h \
+ ivi-shell/ivi-layout.c \
+ ivi-shell/ivi-layout-transition.c
+
+endif
+
+
if ENABLE_SCREEN_SHARING
module_LTLIBRARIES += screen-share.la