summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenoit Gschwind <gschwind@gnu-log.net>2016-04-28 20:33:15 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-05-04 15:40:56 +0300
commit639322a44794f5a61b16d75f69ee9f0aadb91120 (patch)
treed08ef5bc583c30de9a48f04669221c0a74e73195 /Makefile.am
parentcd63b3ea513ae9062f2aabe685f8e67e81183ded (diff)
downloadweston-639322a44794f5a61b16d75f69ee9f0aadb91120.tar.gz
compositor-wayland: put configuration structure in separate header
Signed-off-by: Benoit Gschwind <gschwind@gnu-log.net> [Pekka: moved #include out of extern "C".] Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 810945bc..53458291 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -76,6 +76,7 @@ weston_SOURCES = \
src/compositor-fbdev.h \
src/compositor-rdp.h \
src/compositor-x11.h \
+ src/compositor-wayland.h \
src/input.c \
src/data-device.c \
src/screenshooter.c \
@@ -216,6 +217,7 @@ westoninclude_HEADERS = \
src/compositor-fbdev.h \
src/compositor-rdp.h \
src/compositor-x11.h \
+ src/compositor-wayland.h \
src/timeline-object.h \
shared/matrix.h \
shared/config-parser.h \
@@ -316,6 +318,7 @@ wayland_backend_la_CFLAGS = \
$(AM_CFLAGS)
wayland_backend_la_SOURCES = \
src/compositor-wayland.c \
+ src/compositor-wayland.h \
shared/helpers.h
nodist_wayland_backend_la_SOURCES = \
protocol/fullscreen-shell-unstable-v1-protocol.c \