summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot <emmanuel.peyrot@collabora.com>2016-01-11 19:04:38 +0000
committerDerek Foreman <derekf@osg.samsung.com>2016-01-11 13:34:22 -0600
commit5d43af3e8888f18a4982d980b8c760d9726a9a92 (patch)
treee7baa7e25e435cc868d6ec747ebfd741c74eebcd /Makefile.am
parent8ef2957873fcb6f04b1ec6e5de6b43f63d277e62 (diff)
downloadweston-5d43af3e8888f18a4982d980b8c760d9726a9a92.tar.gz
clients: add simple-v4l-dmabuf client
This client opens a V4L2 device, usually exposed as /dev/videoN, and retrieves its frames as dmabuf for later import into the compositor. It supports both single- and multi-planar devices, and any format exposed by the V4L2 device the Wayland compositor accepts. This client never changes the v4l2 settings, use `v4l2-ctl -c` if you want to change those. Signed-off-by: Emmanuel Gil Peyrot <emmanuel.peyrot@collabora.com> Acked-by: Derek Foreman <derekf@osg.samsung.com> Tested-by: Derek Foreman <derekf@osg.samsung.com> Maniphest Tasks: T90 Differential Revision: https://phabricator.freedesktop.org/D339
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1eb66aeb..623621da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -538,6 +538,21 @@ weston_simple_dmabuf_intel_LDADD = $(SIMPLE_DMABUF_INTEL_CLIENT_LIBS) libshared.
BUILT_SOURCES += protocol/linux-dmabuf-unstable-v1-client-protocol.h
endif
+if BUILD_SIMPLE_DMABUF_V4L_CLIENT
+demo_clients += weston-simple-dmabuf-v4l
+weston_simple_dmabuf_v4l_SOURCES = clients/simple-dmabuf-v4l.c
+nodist_weston_simple_dmabuf_v4l_SOURCES = \
+ protocol/xdg-shell-unstable-v5-protocol.c \
+ protocol/xdg-shell-unstable-v5-client-protocol.h \
+ protocol/fullscreen-shell-unstable-v1-protocol.c \
+ protocol/fullscreen-shell-unstable-v1-client-protocol.h \
+ protocol/linux-dmabuf-unstable-v1-protocol.c \
+ protocol/linux-dmabuf-unstable-v1-client-protocol.h
+weston_simple_dmabuf_v4l_CFLAGS = $(AM_CFLAGS) $(SIMPLE_DMABUF_V4L_CLIENT_CFLAGS)
+weston_simple_dmabuf_v4l_LDADD = $(SIMPLE_DMABUF_V4L_CLIENT_LIBS) libshared.la
+BUILT_SOURCES += protocol/linux-dmabuf-unstable-v1-client-protocol.h
+endif
+
noinst_LTLIBRARIES += libtoytoolkit.la
libtoytoolkit_la_SOURCES = \