summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJon A. Cruz <jonc@osg.samsung.com>2015-07-02 23:36:44 -0700
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-07-07 15:47:08 +0300
commit5a75a41d0737480127d8ed695418c4ae6b735f42 (patch)
treeafbfff14461ca0c088c9161481a17ac380911875 /Makefile.am
parent492c12fb8be4d3fb0b57c4548029cce5a82291c1 (diff)
downloadweston-5a75a41d0737480127d8ed695418c4ae6b735f42.tar.gz
Added simple unit/integration test framework and corresponding test program.
Added a simple C-based test framework and an example program that uses it to run through some simple unit tests. This is new code inspired primarily by the approaches of Google Test, Boost Test, JUnit and TestNG. Factors of others were also considered during design and implementation. Signed-off-by: Jon A. Cruz <jonc@osg.samsung.com> Acked-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am54
1 files changed, 51 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f493d165..4f0a4501 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -932,7 +932,8 @@ endif
# Shared utilities
#
-noinst_LTLIBRARIES += libshared.la libshared-cairo.la
+noinst_LTLIBRARIES += libshared.la libshared-cairo.la \
+ libzunitc.la libzunitcmain.la
libshared_la_CFLAGS = $(AM_CFLAGS) $(COMPOSITOR_CFLAGS)
@@ -971,6 +972,37 @@ libshared_cairo_la_SOURCES = \
shared/frame.c \
shared/cairo-util.h
+libzunitc_la_SOURCES = \
+ tools/zunitc/inc/zunitc/zunitc.h \
+ tools/zunitc/inc/zunitc/zunitc_impl.h \
+ tools/zunitc/src/zuc_base_logger.c \
+ tools/zunitc/src/zuc_base_logger.h \
+ tools/zunitc/src/zuc_collector.c \
+ tools/zunitc/src/zuc_collector.h \
+ tools/zunitc/src/zuc_context.h \
+ tools/zunitc/src/zuc_event.h \
+ tools/zunitc/src/zuc_event_listener.h \
+ tools/zunitc/src/zuc_types.h \
+ tools/zunitc/src/zunitc_impl.c \
+ shared/helpers.h
+
+libzunitc_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ -I$(top_srcdir)/tools/zunitc/inc
+
+libzunitc_la_LIBADD = \
+ libshared.la
+
+libzunitcmain_la_SOURCES = \
+ tools/zunitc/src/main.c
+
+libzunitcmain_la_CFLAGS = \
+ $(AM_CFLAGS) \
+ -I$(top_srcdir)/tools/zunitc/inc
+
+libzunitcmain_la_LIBADD = \
+ libzunitc.la \
+ libshared.la
#
# tests subdirectory
@@ -983,7 +1015,8 @@ internal_tests = \
shared_tests = \
config-parser.test \
- vertex-clip.test
+ vertex-clip.test \
+ zuctest
module_tests = \
surface-test.la \
@@ -1216,6 +1249,22 @@ setbacklight_CFLAGS = $(AM_CFLAGS) $(SETBACKLIGHT_CFLAGS)
setbacklight_LDADD = $(SETBACKLIGHT_LIBS)
endif
+all-local: zuctest$(EXEEXT)
+
+noinst_PROGRAMS += zuctest$(EXEEXT)
+
+zuctest_LDADD = \
+ libzunitc.la \
+ libzunitcmain.la
+
+zuctest_CFLAGS = \
+ $(AM_CFLAGS) \
+ -I$(top_srcdir)/tools/zunitc/inc
+
+zuctest_SOURCES = \
+ tools/zunitc/test/fixtures_test.c \
+ tools/zunitc/test/zunitc_test.c
+
EXTRA_DIST += \
tests/weston-tests-env \
tests/internal-screenshot.ini \
@@ -1285,7 +1334,6 @@ EXTRA_DIST += \
CLEANFILES += $(man_MANS)
-
protocol/%-protocol.c : $(top_srcdir)/protocol/%.xml
$(AM_V_GEN)$(MKDIR_P) $(dir $@) && $(wayland_scanner) code < $< > $@