summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2014-06-12 16:26:49 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-08-14 15:53:26 +0300
commit53868985ff20badbcb70c69055937893fde1d91d (patch)
treefcb1ad34ff661e0a19d6307aeb1abee1b119dd69 /Makefile.am
parentbf8cc6f5a12f34596d2e9ae002f45eefc007c481 (diff)
downloadweston-53868985ff20badbcb70c69055937893fde1d91d.tar.gz
clients: add simple-dmabuf client
v2: - adapted to protocol changes - added TODO comments - minor clean-up - change y-invert from per-plane boolean to per-buffer flag v3: - fix a typo: 1 -> i (noticed by Carlos Olmedo Escobar) Signed-off-by: George Kiagiadakis <george.kiagiadakis@collabora.com> Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Signed-off-by: Louis-Francis Ratté-Boulianne <lfrb@collabora.com> Acked-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f50587e1..62719c95 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -503,6 +503,21 @@ weston_simple_egl_CFLAGS = $(AM_CFLAGS) $(SIMPLE_EGL_CLIENT_CFLAGS)
weston_simple_egl_LDADD = $(SIMPLE_EGL_CLIENT_LIBS) -lm
endif
+if BUILD_SIMPLE_INTEL_DMABUF_CLIENT
+demo_clients += weston-simple-dmabuf
+weston_simple_dmabuf_SOURCES = clients/simple-dmabuf.c
+nodist_weston_simple_dmabuf_SOURCES = \
+ protocol/xdg-shell-protocol.c \
+ protocol/xdg-shell-client-protocol.h \
+ protocol/fullscreen-shell-protocol.c \
+ protocol/fullscreen-shell-client-protocol.h \
+ protocol/linux-dmabuf-protocol.c \
+ protocol/linux-dmabuf-client-protocol.h
+weston_simple_dmabuf_CFLAGS = $(AM_CFLAGS) $(SIMPLE_DMABUF_CLIENT_CFLAGS)
+weston_simple_dmabuf_LDADD = $(SIMPLE_DMABUF_CLIENT_LIBS) libshared.la
+BUILT_SOURCES += protocol/linux-dmabuf-client-protocol.h
+endif
+
noinst_LTLIBRARIES += libtoytoolkit.la
libtoytoolkit_la_SOURCES = \