summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot <emmanuel.peyrot@collabora.com>2016-01-11 19:04:36 +0000
committerDerek Foreman <derekf@osg.samsung.com>2016-01-11 13:30:49 -0600
commit3b65b0b38f63e46bbf2b3aae5a71ba2fa9c7545a (patch)
treea21c5d55f1fee2d24902b48928186bd860406bc3 /Makefile.am
parentbc35fdaed14563832c1f983181a9176909caef29 (diff)
downloadweston-3b65b0b38f63e46bbf2b3aae5a71ba2fa9c7545a.tar.gz
clients: rename simple-dmabuf into simple-dmabuf-intel
This client was using an Intel-specific way to allocate a dmabuf, so it makes sense to have that in its name. Signed-off-by: Emmanuel Gil Peyrot <emmanuel.peyrot@collabora.com> Reviewed-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Daniel Stone <daniels@collabora.com> Reviewed-by: Derek Foreman <derekf@osg.samsung.com> Differential Revision: https://phabricator.freedesktop.org/D342
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index cbb3b579..1eb66aeb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -523,18 +523,18 @@ weston_simple_egl_CFLAGS = $(AM_CFLAGS) $(SIMPLE_EGL_CLIENT_CFLAGS)
weston_simple_egl_LDADD = $(SIMPLE_EGL_CLIENT_LIBS) -lm
endif
-if BUILD_SIMPLE_INTEL_DMABUF_CLIENT
-demo_clients += weston-simple-dmabuf
-weston_simple_dmabuf_SOURCES = clients/simple-dmabuf.c
-nodist_weston_simple_dmabuf_SOURCES = \
+if BUILD_SIMPLE_DMABUF_INTEL_CLIENT
+demo_clients += weston-simple-dmabuf-intel
+weston_simple_dmabuf_intel_SOURCES = clients/simple-dmabuf-intel.c
+nodist_weston_simple_dmabuf_intel_SOURCES = \
protocol/xdg-shell-unstable-v5-protocol.c \
protocol/xdg-shell-unstable-v5-client-protocol.h \
protocol/fullscreen-shell-unstable-v1-protocol.c \
protocol/fullscreen-shell-unstable-v1-client-protocol.h \
protocol/linux-dmabuf-unstable-v1-protocol.c \
protocol/linux-dmabuf-unstable-v1-client-protocol.h
-weston_simple_dmabuf_CFLAGS = $(AM_CFLAGS) $(SIMPLE_DMABUF_CLIENT_CFLAGS)
-weston_simple_dmabuf_LDADD = $(SIMPLE_DMABUF_CLIENT_LIBS) libshared.la
+weston_simple_dmabuf_intel_CFLAGS = $(AM_CFLAGS) $(SIMPLE_DMABUF_INTEL_CLIENT_CFLAGS)
+weston_simple_dmabuf_intel_LDADD = $(SIMPLE_DMABUF_INTEL_CLIENT_LIBS) libshared.la
BUILT_SOURCES += protocol/linux-dmabuf-unstable-v1-client-protocol.h
endif