summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-02-18 16:56:13 +0200
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-02-23 14:21:00 +0200
commit35552aafc78405cf90d6895edfe51e5e859363da (patch)
tree8feaf1bb3ea38fe1eb4bddc785b33bf1118ee7c0 /Makefile.am
parent2e49794f0fb3afeca2fd1646a3485d073ff03f87 (diff)
downloadweston-35552aafc78405cf90d6895edfe51e5e859363da.tar.gz
Makefile: handle also stable wayland-protocols
Fix the protostability function to handle stable protocol files correctly. Stable protocol XML file names do not have 'stable' in their name, nor do we want to write that in the prerequisite lists in the Makefile. Function 'protoname' does not need fixing, because for stable protocol prerequisites, the sed pattern will not match, and it passes stem through as is, which is correct. Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Reviewed-by: Bryce Harrington <bryce@osg.samsung.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e3653964..505d40a9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1423,7 +1423,7 @@ doc: $(DOXYGEN_INDICES)
.SECONDEXPANSION:
define protostability
-$(shell echo $1 | sed 's/.*\(\<unstable\>\|\<stable\>\).*/\1/')
+$(if $(findstring unstable,$1),unstable,stable)
endef
define protoname