summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.co.uk>2014-09-29 14:18:40 -0400
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-08-14 15:53:25 +0300
commit230f3b1bf896fcf3fa76b4d7093122b3361f7e36 (patch)
tree8a8627c2d4e31bff6f4cc30d534931c1268871d4 /Makefile.am
parent23ab7159d200883cc0d21db8dc4efdd58e2d60a7 (diff)
downloadweston-230f3b1bf896fcf3fa76b4d7093122b3361f7e36.tar.gz
dmabuf: implement linux_dmabuf extension
v2 changes: - implement the revised protocol - add basic sanity checks when creating buffer and check for support - add way to attach user data to the dmabuf for renderer use - bump max number of planes to 4 to follow DRM AddFb2 ioctl - improve errors handling - use separate linux_dmabuf_buffer fields for the different wl_resource types - as SERVER_ERROR code is no more, use a wl_display "generic" error for emergency-disconneting a client we fail to process - more documentation - change y-invert from per-plane boolean to per-buffer flag Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Signed-off-by: Louis-Francis Ratté-Boulianne <lfrb@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7acbc2de..9c1cf258 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,6 +87,8 @@ weston_SOURCES = \
src/timeline.h \
src/timeline-object.h \
src/main.c \
+ src/linux-dmabuf.c \
+ src/linux-dmabuf.h \
shared/helpers.h \
shared/matrix.c \
shared/matrix.h \