summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGiulio Camuffo <giuliocamuffo@gmail.com>2016-04-29 15:40:34 -0700
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2016-05-10 15:23:03 +0300
commit1c0e40d9a272c99c3f45ce2e15f8214165770912 (patch)
treed60ea3edc30a3394798e1828cf171a426cfdc318 /Makefile.am
parent59987fa1724367c78d9971c5ece22cccc04b2ad7 (diff)
downloadweston-1c0e40d9a272c99c3f45ce2e15f8214165770912.tar.gz
drm: port the drm backend to the new init api
Preparing for libweston and for the separation of the code base into libweston vs. weston the compositor, we must remove all uses weston_config structures from the backends. We have decided that all option and config input happens in the compositor (main.c), and configuration is passed in for the backends as structs. Most other backends have already converted, and this patch converts the DRM-backend to the libweston-style init API. The libweston-style init API includes a header for each backend (here compositor-drm.h) defining the configuration interface. The compositor (main.c) prepares a configuration struct to be passed through libweston core to the backend during initialization. A complication with the DRM-backend is that outputs can be hotplugged, and their configuration needs to be fetched from the compositor (main.c). For this, the config struct contains a callback member. The output configuration API is subject to change later, this is just a temporary API to get libweston forward. As weston_compositor's user_data was not previously used for anything, and the output configuration callback needs data, the user_data is set to the 'config' pointer. This pointer is only used in drm_configure_output() in main.c. [Bryce: lots of stuff and rebasing] Signed-off-by: Bryce Harrington <bryce@osg.samsung.com> Reviewed-by: Quentin Glidic <sardemff7+git@sardemff7.net> Acked-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Tested-by: Benoit Gschwind <gschwind@gnu-log.net> [Pekka: write commit message] [Pekka: squash in "drm: Don't hang onto the backend config object post-backend_init" from Bryce Harrington] [Pekka: drop the compositor.h hunk] [Pekka: do not #include inside extern "C"] [Pekka: remove incorrect comment about weston_drm_backend_config ownership.] Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 53458291..0b7aa35e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -72,11 +72,12 @@ weston_SOURCES = \
src/log.c \
src/compositor.c \
src/compositor.h \
- src/compositor-headless.h \
+ src/compositor-drm.h \
src/compositor-fbdev.h \
+ src/compositor-headless.h \
src/compositor-rdp.h \
- src/compositor-x11.h \
src/compositor-wayland.h \
+ src/compositor-x11.h \
src/input.c \
src/data-device.c \
src/screenshooter.c \
@@ -213,11 +214,12 @@ westonincludedir = $(includedir)/weston
westoninclude_HEADERS = \
src/version.h \
src/compositor.h \
- src/compositor-headless.h \
+ src/compositor-drm.h \
src/compositor-fbdev.h \
+ src/compositor-headless.h \
src/compositor-rdp.h \
- src/compositor-x11.h \
src/compositor-wayland.h \
+ src/compositor-x11.h \
src/timeline-object.h \
shared/matrix.h \
shared/config-parser.h \
@@ -289,6 +291,7 @@ drm_backend_la_CFLAGS = \
$(AM_CFLAGS)
drm_backend_la_SOURCES = \
src/compositor-drm.c \
+ src/compositor-drm.h \
$(INPUT_BACKEND_SOURCES) \
shared/helpers.h \
shared/timespec-util.h \