summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-04-14 10:25:33 +0300
committerPekka Paalanen <pekka.paalanen@collabora.co.uk>2015-06-22 15:19:14 +0300
commit0a9d348fd8e9672185dfebefd52e3dfeaa8c68cd (patch)
treee0430ac8e136b79dfc853a6b81b7d759152621f4 /Makefile.am
parente28ee34214e9f8dfae30f1ebd4446bee731e0074 (diff)
downloadweston-0a9d348fd8e9672185dfebefd52e3dfeaa8c68cd.tar.gz
Remove weston-screensaver
This removes the weston-screensaver client. Screensavers are not so useful, DPMS is much better. This example has existed here for a good while, and things that we could learn from it have been learnt. Nowadays this is just dead weigth, which is usually not even compiled, because it depends on both cairo-gl and GLU. Removing it removes the only possible dependency to GLU and one user of cairo-gl. Now the last user of cairo-gl is gears (clients/nested.c uses cairo-glesv2). Support for screensavers is still left in desktop-shell, so external projects can still have their screensavers if they want. Signed-off-by: Pekka Paalanen <pekka.paalanen@collabora.co.uk> Acked-by: Giulio Camuffo <giuliocamuffo@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 0 insertions, 20 deletions
diff --git a/Makefile.am b/Makefile.am
index 6b2d6c71..39f1f8c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -700,26 +700,6 @@ demo_clients += weston-gears
weston_gears_SOURCES = clients/gears.c
weston_gears_LDADD = libtoytoolkit.la
weston_gears_CFLAGS = $(AM_CFLAGS) $(CLIENT_CFLAGS)
-
-if HAVE_GLU
-libexec_PROGRAMS += weston-screensaver
-weston_screensaver_SOURCES = \
- clients/wscreensaver.c \
- clients/wscreensaver.h \
- clients/wscreensaver-glue.c \
- clients/wscreensaver-glue.h \
- clients/glmatrix.c \
- clients/matrix3.xpm \
- shared/helpers.h
-nodist_weston_screensaver_SOURCES = \
- protocol/desktop-shell-client-protocol.h \
- protocol/desktop-shell-protocol.c
-
-weston_screensaver_LDADD = libtoytoolkit.la $(GLU_LIBS)
-weston_screensaver_CFLAGS = $(AM_CFLAGS) $(GLU_CFLAGS) $(CLIENT_CFLAGS)
-
-endif
-
endif
endif