summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 1e7479b..77f7e15 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -17,10 +17,10 @@ classifiers = [
"Operating System :: POSIX",
"Programming Language :: Python",
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
"Topic :: Software Development :: Libraries :: Python Modules",
]
packages = [
@@ -28,13 +28,13 @@ packages = [
]
[tool.poetry.dependencies]
-python = "^3.5"
+python = "^3.7"
jsonschema = "^4"
jsonpatch = "^1"
[tool.poetry.dev-dependencies]
-pytest = "^5.0"
-pytest-cov = "^2.8"
+pytest = "^6.0"
+pytest-cov = "^3.0"
[tool.black]
line-length = 88