summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 1 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 2e1215c0..658e6503 100755
--- a/setup.py
+++ b/setup.py
@@ -586,16 +586,12 @@ class CheckPylint(distutils.core.Command):
"tests"]
output_format = sys.stdout.isatty() and "colorized" or "text"
- exclude = ["virtinst/progress.py"]
print("running pycodestyle")
style_guide = pycodestyle.StyleGuide(
config_file='tests/pycodestyle.cfg',
paths=files
)
- style_guide.options.exclude = pycodestyle.normalize_paths(
- ','.join(exclude)
- )
report = style_guide.check_files()
if style_guide.options.count:
sys.stderr.write(str(report.total_errors) + '\n')
@@ -604,7 +600,7 @@ class CheckPylint(distutils.core.Command):
pylint_opts = [
"--rcfile", "tests/pylint.cfg",
"--output-format=%s" % output_format,
- ] + ["--ignore"] + [os.path.basename(p) for p in exclude]
+ ]
if self.jobs:
pylint_opts += ["--jobs=%d" % self.jobs]