summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRadostin Stoyanov <rstoyanov1@gmail.com>2018-10-25 13:37:42 +0100
committerCole Robinson <crobinso@redhat.com>2018-11-12 08:34:55 -0500
commit5b1f6ad2b8207d713c44e2f5beb36058ef8d0500 (patch)
tree53e0fa9d9b7f60054429ae37bdfc79e54aed43c7 /setup.py
parent9308bae310ff7889876d8c9d6f0187356e0fa2ce (diff)
downloadvirt-manager-5b1f6ad2b8207d713c44e2f5beb36058ef8d0500.tar.gz
pylint: Don't exclude progress.py
Currently progress.py file was excluded from pylint/pycodestyle check because the code was straight from python-urlgrabber and it was not PEP8 compliant. The following patched resolve the code style issues. Signed-off-by: Radostin Stoyanov <rstoyanov1@gmail.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 1 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 2e1215c0..658e6503 100755
--- a/setup.py
+++ b/setup.py
@@ -586,16 +586,12 @@ class CheckPylint(distutils.core.Command):
"tests"]
output_format = sys.stdout.isatty() and "colorized" or "text"
- exclude = ["virtinst/progress.py"]
print("running pycodestyle")
style_guide = pycodestyle.StyleGuide(
config_file='tests/pycodestyle.cfg',
paths=files
)
- style_guide.options.exclude = pycodestyle.normalize_paths(
- ','.join(exclude)
- )
report = style_guide.check_files()
if style_guide.options.count:
sys.stderr.write(str(report.total_errors) + '\n')
@@ -604,7 +600,7 @@ class CheckPylint(distutils.core.Command):
pylint_opts = [
"--rcfile", "tests/pylint.cfg",
"--output-format=%s" % output_format,
- ] + ["--ignore"] + [os.path.basename(p) for p in exclude]
+ ]
if self.jobs:
pylint_opts += ["--jobs=%d" % self.jobs]