summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPino Toscano <ptoscano@redhat.com>2020-07-08 16:54:12 +0200
committerCole Robinson <crobinso@redhat.com>2020-07-11 14:59:56 -0400
commitfdc902e4614b3351867aedade15bb70525df55b7 (patch)
tree5af1b54cbaf2fe161cb0f879a222792e55f8d0a8 /setup.py
parenta8d2438d5a4725825af936c72ccffad3d5c7b992 (diff)
downloadvirt-manager-fdc902e4614b3351867aedade15bb70525df55b7.tar.gz
setup: split listing of .in sources for POTFILES
Extract them from _generate_potfiles_in() to an own _generate_meta_potfiles_in() function. Reviewed-by: Cole Robinson <crobinso@redhat.com> Signed-off-by: Pino Toscano <ptoscano@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 9d130dc3..3e921b45 100755
--- a/setup.py
+++ b/setup.py
@@ -59,6 +59,13 @@ _appdata_files = [
]
+def _generate_meta_potfiles_in():
+ potfiles = ""
+ for ignore, filelist in _desktop_files + _appdata_files:
+ potfiles += "\n".join(filelist) + "\n"
+ return potfiles
+
+
def _generate_potfiles_in():
def find(dirname, ext):
ret = []
@@ -72,8 +79,7 @@ def _generate_potfiles_in():
potfiles += "\n".join(find("virtManager", "*.py")) + "\n\n"
potfiles += "\n".join(find("virtinst", "*.py")) + "\n\n"
- for ignore, filelist in _desktop_files + _appdata_files:
- potfiles += "\n".join(filelist) + "\n"
+ potfiles += _generate_meta_potfiles_in()
potfiles += "\n"
potfiles += "\n".join(["[type: gettext/glade]" + f for