summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2020-01-24 16:18:00 -0500
committerCole Robinson <crobinso@redhat.com>2020-01-24 17:04:29 -0500
commitee9f93074bf74bd2e4c5177d750e7c438c7790cf (patch)
treea3d4ba5ec704ff939b9dd72f58e36961aded1fb9 /setup.py
parentcdbc3f56e61543ca77c1d31463d1d9a1bade900a (diff)
downloadvirt-manager-ee9f93074bf74bd2e4c5177d750e7c438c7790cf.tar.gz
Remove virt-convert
This was raised here: https://www.redhat.com/archives/virt-tools-list/2019-June/msg00117.html Quoting from that: """ virt-convert takes an ovf/ova or vmx file and spits out libvirt XML. It started as a code drop a long time ago that could translate back and forth between vmx, ovf, and virt-image, a long dead appliance format. In 2014 I converted it to do vmx -> libvirt and ovf -> libvirt which was a CLI breaking change, but I never heard a peep of a complaint. It doesn't seem to do a particularly thorough job at its intended goal, I've seen 2-3 bug reports in the past 5 years and generally it doesn't seem to have any users. Let's kill it. If anyone has the desire to keep it alive it could live as a separate project that's a wrapper around virt-install but there's no compelling reason to keep it in virt-manager.git IMO """ Nothing has changed since then, so here is the removal. Signed-off-by: Cole Robinson <crobinso@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 5 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index ff15843f..8d999bc1 100755
--- a/setup.py
+++ b/setup.py
@@ -69,11 +69,10 @@ def _generate_potfiles_in():
return ret
scripts = ["virt-manager", "virt-install",
- "virt-clone", "virt-convert", "virt-xml"]
+ "virt-clone", "virt-xml"]
potfiles = "\n".join(scripts) + "\n\n"
potfiles += "\n".join(find("virtManager", "*.py")) + "\n\n"
- potfiles += "\n".join(find("virtconv", "*.py")) + "\n\n"
potfiles += "\n".join(find("virtinst", "*.py")) + "\n\n"
for ignore, filelist in _desktop_files + _appdata_files:
@@ -181,7 +180,7 @@ class my_build(distutils.command.build.build):
def _make_bin_wrappers(self):
cmds = ["virt-manager", "virt-install", "virt-clone",
- "virt-convert", "virt-xml"]
+ "virt-xml"]
if not os.path.exists("build"):
os.mkdir("build")
@@ -237,7 +236,7 @@ class my_build(distutils.command.build.build):
def _make_bash_completion_files(self):
- scripts = ["virt-install", "virt-clone", "virt-convert", "virt-xml"]
+ scripts = ["virt-install", "virt-clone", "virt-xml"]
srcfile = "data/bash-completion.sh.in"
builddir = "build/bash-completion/"
if not os.path.exists(builddir):
@@ -607,8 +606,8 @@ class CheckPylint(distutils.core.Command):
import pycodestyle
files = ["setup.py", "virt-install", "virt-clone",
- "virt-convert", "virt-xml", "virt-manager",
- "virtinst", "virtconv", "virtManager",
+ "virt-xml", "virt-manager",
+ "virtinst", "virtManager",
"tests"]
try:
@@ -671,7 +670,6 @@ distutils.core.setup(
"build/virt-manager",
"build/virt-clone",
"build/virt-install",
- "build/virt-convert",
"build/virt-xml"]),
data_files=[
@@ -679,7 +677,6 @@ distutils.core.setup(
"virt-manager",
"virt-install",
"virt-clone",
- "virt-convert",
"virt-xml",
]),
("share/glib-2.0/schemas",
@@ -690,7 +687,6 @@ distutils.core.setup(
"man/virt-manager.1",
"man/virt-install.1",
"man/virt-clone.1",
- "man/virt-convert.1",
"man/virt-xml.1"
]),
@@ -711,8 +707,6 @@ distutils.core.setup(
glob.glob("virtinst/domain/*.py")),
("share/virt-manager/virtinst/install",
glob.glob("virtinst/install/*.py")),
- ("share/virt-manager/virtconv",
- glob.glob("virtconv/*.py")),
],
cmdclass={