summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2020-07-05 08:30:14 -0400
committerCole Robinson <crobinso@redhat.com>2020-07-17 14:57:03 -0400
commite9b3ed509fb4c92848e99d8fc841745cf3097a55 (patch)
tree45d515d9aca7eb3ddd3fe092d7fa0f29979813e0 /setup.py
parent4f15e2d6eb323d41cf52a20dd07c7d62c4dea23f (diff)
downloadvirt-manager-e9b3ed509fb4c92848e99d8fc841745cf3097a55.tar.gz
tests: Add pytest conftest.py
Makes 'pytest' and 'pytest --cov' work for the standard tests. uitests run with `pytest --uitests --cov=virtManager`. test_urls.py, test_dist.py, test_inject.py need to be invoked like pytest $PATH Signed-off-by: Cole Robinson <crobinso@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 06c2f50b..48d0d157 100755
--- a/setup.py
+++ b/setup.py
@@ -410,7 +410,7 @@ class TestBaseCommand(distutils.core.Command):
if self.coverage:
import coverage
omit = ["/usr/*", "/*/tests/*", "*progress.py"]
- cov = coverage.coverage(omit=omit)
+ cov = coverage.coverage()
cov.erase()
if not self._external_coverage:
cov.start()