summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2015-09-18 20:28:55 -0400
committerCole Robinson <crobinso@redhat.com>2015-09-18 20:55:44 -0400
commitd5d6cfff2c867119c685f91507be7f529b0a0769 (patch)
tree4197e2762f701904246c9b794b4ed441a6a151b5 /setup.py
parent5584863d18b5b0ffed9bb75a4a2cc7b11df8863d (diff)
downloadvirt-manager-d5d6cfff2c867119c685f91507be7f529b0a0769.tar.gz
Copy urlgrabber progress bar code into virt-manager.git
This is so we can drop the dep on system python-urlgrabber, which will block us from going to python3. All we need is like 300 lines from python-urlgrabber for the progress bar. In reality our needs are much lower, we don't need the fancy progress bar that urlgrabber provides, but it's nice to have. So if keeping a copy of this code causes issues in the future, we can probably come up with something simpler (or hopefully there's a more common python progressbar impl that we can use at that point).
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 8 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 77eccabf..0fa8fcb0 100755
--- a/setup.py
+++ b/setup.py
@@ -567,17 +567,23 @@ class CheckPylint(Command):
"tests"]
output_format = sys.stdout.isatty() and "colorized" or "text"
+ exclude = ["virtinst/progress.py"]
print "running pep8"
cmd = "pep8 "
+ cmd += "--config tests/pep8.cfg "
+ cmd += "--exclude %s " % ",".join(exclude)
cmd += " ".join(files)
- os.system(cmd + " --config tests/pep8.cfg")
+ os.system(cmd)
print "running pylint"
cmd = "pylint "
+ cmd += "--rcfile tests/pylint.cfg "
cmd += "--output-format=%s " % output_format
+ cmd += "--ignore %s " % ",".join(
+ [os.path.basename(p) for p in exclude])
cmd += " ".join(files)
- os.system(cmd + " --rcfile tests/pylint.cfg")
+ os.system(cmd)
setup(