summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPino Toscano <ptoscano@redhat.com>2020-07-08 16:54:14 +0200
committerCole Robinson <crobinso@redhat.com>2020-07-11 14:59:56 -0400
commita1f0e07cd916a59b4ad2c1071f3b25384f8eeddd (patch)
tree2af7270cada2d68dc1a60da757b7d174f86cde82 /setup.py
parentd306d7ef7c5ba4a4e1dfbfaecc62061ada99e0d6 (diff)
downloadvirt-manager-a1f0e07cd916a59b4ad2c1071f3b25384f8eeddd.tar.gz
setup: use msgmerge for updating translations
Switch from intltool to msgmerge to merge the translations to the catalog, as it is much easier. Remove the writing of the temporary POTFILES.in, as it is no more needed now. Also, since now gettext is used at installation time: - mention the gettext requirement in INSTALL.md - add the gettext BuildRequires in the RPM spec file Reviewed-by: Cole Robinson <crobinso@redhat.com> Signed-off-by: Pino Toscano <ptoscano@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py50
1 files changed, 5 insertions, 45 deletions
diff --git a/setup.py b/setup.py
index 17ea4ef8..95d9a7a1 100755
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,6 @@ if sys.version_info.major < 3:
sys.exit(1)
import glob
-import fnmatch
import os
from pathlib import Path
import unittest
@@ -67,28 +66,6 @@ def _generate_meta_potfiles_in():
return potfiles
-def _generate_potfiles_in():
- def find(dirname, ext):
- ret = []
- for root, ignore, filenames in os.walk(dirname):
- for filename in fnmatch.filter(filenames, ext):
- ret.append(os.path.join(root, filename))
- ret.sort(key=lambda s: s.lower())
- return ret
-
- potfiles = ""
- potfiles += "\n".join(find("virtManager", "*.py")) + "\n\n"
- potfiles += "\n".join(find("virtinst", "*.py")) + "\n\n"
-
- potfiles += _generate_meta_potfiles_in()
- potfiles += "\n"
-
- potfiles += "\n".join(["[type: gettext/glade]" + f for
- f in find("ui", "*.ui")]) + "\n\n"
-
- return potfiles
-
-
class my_build_i18n(distutils.command.build.build):
"""
Add our desktop files to the list, saves us having to track setup.cfg
@@ -103,30 +80,13 @@ class my_build_i18n(distutils.command.build.build):
pass
def run(self):
- potfiles = _generate_potfiles_in()
- potpath = "po/POTFILES.in"
-
- try:
- print("Writing %s" % potpath)
- open(potpath, "w").write(potfiles)
- self._run()
- finally:
- print("Removing %s" % potpath)
- os.unlink(potpath)
-
- def _run(self):
- # Borrowed from python-distutils-extra
po_dir = "po"
+ if self.merge_po:
+ pot_file = os.path.join("po", "virt-manager.pot")
+ for po_file in glob.glob("%s/*.po" % po_dir):
+ cmd = ["msgmerge", "--previous", "-o", po_file, po_file, pot_file]
+ self.spawn(cmd)
- # Update po(t) files and print a report
- # We have to change the working dir to the po dir for intltool
- cmd = ["intltool-update",
- (self.merge_po and "-r" or "-p"), "-g", "virt-manager"]
-
- wd = os.getcwd()
- os.chdir("po")
- self.spawn(cmd)
- os.chdir(wd)
max_po_mtime = 0
for po_file in glob.glob("%s/*.po" % po_dir):
lang = os.path.basename(po_file[:-3])