summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMiro HronĨok <miro@hroncok.cz>2022-08-02 16:39:36 +0200
committerCole Robinson <crobinso@redhat.com>2022-08-02 12:05:39 -0400
commit90e13549b4f2dd74b3343a3a28c30f31c20032d5 (patch)
tree644bf61031e124f52e51512c0b8dfbfc349a33d6 /setup.py
parent0d84bcfbfa2aa08396e836cb37fd0df167a6f6a4 (diff)
downloadvirt-manager-90e13549b4f2dd74b3343a3a28c30f31c20032d5.tar.gz
Fix build with setuptools 61+
+ ./setup.py configure --default-hvs qemu,xen,lxc error: Multiple top-level packages discovered in a flat-layout: ['po', 'ui', 'man', 'data', 'virtinst', 'virtManager']. To avoid accidental inclusion of unwanted files or directories, setuptools will not proceed with this build. If you are trying to create a single distribution with multiple packages on purpose, you should not rely on automatic discovery. Instead, consider the following options: 1. set up custom discovery (`find` directive with `include` or `exclude`) 2. use a `src-layout` 3. explicitly set `py_modules` or `packages` with a list of names To find more information, look for "package discovery" on setuptools docs. Downstream bug report: https://bugzilla.redhat.com/2113754
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6a546606..b45d315a 100755
--- a/setup.py
+++ b/setup.py
@@ -530,6 +530,9 @@ setuptools.setup(
glob.glob("virtinst/install/*.py")),
],
+ # stop setuptools 61+ thinking we want to include everything automatically
+ py_modules=[],
+
cmdclass={
'build': my_build,
'build_i18n': my_build_i18n,