summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2020-07-17 14:27:53 -0400
committerCole Robinson <crobinso@redhat.com>2020-07-17 16:00:32 -0400
commit62e7f1c521416aed788571e187b783a19e87ea97 (patch)
treeb7d4e10b48e9bc11dbc1472f034efdf650474851 /setup.py
parentb9dfd92bf081de4b2b5f6a0483f8730cb7a25367 (diff)
downloadvirt-manager-62e7f1c521416aed788571e187b783a19e87ea97.tar.gz
spec: Move virt-manager.spec.in -> virt-manager.spec
Drop the VERSION templating. Tools today like packit and tito work best when a working .spec file exists. The extra burden is we need to update the version at release time, but that's no big deal Signed-off-by: Cole Robinson <crobinso@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py18
1 files changed, 1 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 9c4318f4..ad932436 100755
--- a/setup.py
+++ b/setup.py
@@ -19,7 +19,6 @@ import distutils.command.build
import distutils.command.install
import distutils.command.install_data
import distutils.command.install_egg_info
-import distutils.command.sdist
import distutils.dist
import distutils.log
import distutils.sysconfig
@@ -283,20 +282,6 @@ class my_install_data(distutils.command.install_data.install_data):
self.spawn(["glib-compile-schemas", gschema_install])
-class my_sdist(distutils.command.sdist.sdist):
- description = "Update virt-manager.spec; build sdist-tarball."
-
- def run(self):
- f1 = open('virt-manager.spec.in', 'r')
- f2 = open('virt-manager.spec', 'w')
- for line in f1:
- f2.write(line.replace('@VERSION@', BuildConfig.version))
- f1.close()
- f2.close()
-
- distutils.command.sdist.sdist.run(self)
-
-
###################
# Custom commands #
###################
@@ -394,7 +379,7 @@ class CheckPylint(distutils.core.Command):
spellfiles += ["data/virt-manager.appdata.xml.in",
"data/virt-manager.desktop.in",
"data/org.virt-manager.virt-manager.gschema.xml",
- "virt-manager.spec.in"]
+ "virt-manager.spec"]
spellfiles.remove("NEWS.md")
try:
@@ -546,7 +531,6 @@ distutils.core.setup(
'build': my_build,
'build_i18n': my_build_i18n,
- 'sdist': my_sdist,
'install': my_install,
'install_data': my_install_data,
'install_egg_info': my_egg_info,