summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2019-06-17 01:27:08 -0400
committerCole Robinson <crobinso@redhat.com>2019-06-17 01:27:08 -0400
commit5ef458a428b3288bef50c9827793801e63e5455b (patch)
treeef25c4b8484801bbfe8dfb6ed319a9297aa5b84e /setup.py
parentfab6b9ef78c5dc328ef8f1588f6a1f959cc3f0a2 (diff)
downloadvirt-manager-5ef458a428b3288bef50c9827793801e63e5455b.tar.gz
setup: Undo previous file search changes
They were totally busted
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py31
1 files changed, 18 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index cb342c60..6cfc75b4 100755
--- a/setup.py
+++ b/setup.py
@@ -663,16 +663,6 @@ class VMMDistribution(distutils.dist.Distribution):
distutils.dist.Distribution.__init__(self, *args, **kwargs)
-def _py_files(directory):
- paths = []
- for (path, directories, filenames) in os.walk(directory):
- dummy = directories
- for filename in filenames:
- if filename.endswith(".py"):
- paths.append(os.path.join('..', path, filename))
- return paths
-
-
distutils.core.setup(
name="virt-manager",
version=VERSION,
@@ -709,10 +699,25 @@ distutils.core.setup(
"man/virt-xml.1"
]),
- ("share/virt-manager/virtManager", _py_files("virtManager")),
+ ("share/virt-manager/virtManager", glob.glob("virtManager/*.py")),
+ ("share/virt-manager/virtManager/details",
+ glob.glob("virtManager/details/*.py")),
+ ("share/virt-manager/virtManager/device",
+ glob.glob("virtManager/device/*.py")),
+ ("share/virt-manager/virtManager/lib",
+ glob.glob("virtManager/lib/*.py")),
+ ("share/virt-manager/virtManager/object",
+ glob.glob("virtManager/object/*.py")),
("share/virt-manager/virtinst",
- _py_files("virtinst") + glob.glob("virtinst/build.cfg")),
- ("share/virt-manager/virtconv", _py_files("virtconv")),
+ glob.glob("virtinst/*.py") + glob.glob("virtinst/build.cfg")),
+ ("share/virt-manager/virtinst/devices",
+ glob.glob("virtinst/devices/*.py")),
+ ("share/virt-manager/virtinst/domain",
+ glob.glob("virtinst/domain/*.py")),
+ ("share/virt-manager/virtinst/install",
+ glob.glob("virtinst/install/*.py")),
+ ("share/virt-manager/virtconv",
+ glob.glob("virtconv/*.py")),
],
cmdclass={