summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2021-04-06 18:28:18 -0400
committerCole Robinson <crobinso@redhat.com>2021-04-06 18:28:48 -0400
commit5b93a43622d4d47aa8920233a18dda501fae7c54 (patch)
tree4aa40a113dab74197db1e63295a07654a675f9c0 /setup.py
parent511857b2884950b91c19bf12b6f703a23a52066a (diff)
downloadvirt-manager-5b93a43622d4d47aa8920233a18dda501fae7c54.tar.gz
pylint: Make sure we lint against Gtk3
We need to pass virtmanager.py to pylint first, so it detects the require_version() call Signed-off-by: Cole Robinson <crobinso@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6574d95a..bfc4f91c 100755
--- a/setup.py
+++ b/setup.py
@@ -366,7 +366,14 @@ class CheckPylint(distutils.core.Command):
import pylint.lint
import pycodestyle
- lintfiles = ["setup.py", "virtinst", "virtManager", "tests"]
+ lintfiles = [
+ "setup.py",
+ "tests",
+ "virtinst",
+ # Put this first so pylint learns what Gtk version we
+ # want to lint against
+ "virtManager/virtmanager.py",
+ "virtManager"]
spellfiles = lintfiles[:]
spellfiles += list(glob.glob("*.md"))