summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2015-04-21 20:12:37 -0400
committerCole Robinson <crobinso@redhat.com>2015-04-21 20:15:37 -0400
commit4c361933ea606ecb5648ebc10bcfaef6f4aa04c7 (patch)
tree964a0192180b1740be402a4c9a1628ef542ac43f /setup.py
parentccc0da3e5173a6cc4b0a7244f80db1c17c83ccf0 (diff)
downloadvirt-manager-4c361933ea606ecb5648ebc10bcfaef6f4aa04c7.tar.gz
tests: Have the property checker work on whole test suite
Not just xmlparse.py. So we can test a new property via clitest and not always via xmlparse
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py15
1 files changed, 14 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8174ffcb..94549779 100755
--- a/setup.py
+++ b/setup.py
@@ -445,7 +445,7 @@ class TestCommand(TestBaseCommand):
Finds all the tests modules in tests/, and runs them.
'''
testfiles = []
- for t in glob.glob(os.path.join(self._dir, 'tests', '*.py')):
+ for t in sorted(glob.glob(os.path.join(self._dir, 'tests', '*.py'))):
if (t.endswith("__init__.py") or
t.endswith("test_urls.py") or
t.endswith("test_inject.py")):
@@ -461,6 +461,19 @@ class TestCommand(TestBaseCommand):
testfiles.append('.'.join(['tests', os.path.splitext(base)[0]]))
+ # Put clitest at the end, since it takes the longest
+ for f in testfiles[:]:
+ if "clitest" in f:
+ testfiles.remove(f)
+ testfiles.append(f)
+
+ # Always want to put checkprops at the end to get accurate results
+ for f in testfiles[:]:
+ if "checkprops" in f:
+ testfiles.remove(f)
+ if not self.testfile and not self.skipcli:
+ testfiles.append(f)
+
if not testfiles:
raise RuntimeError("--testfile didn't catch anything")