summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRyan Schmidt <git@ryandesign.com>2022-06-03 15:05:15 -0500
committerCole Robinson <crobinso@redhat.com>2022-06-13 15:18:19 -0400
commit49c2e046a1d68cbc8fc0263d2bb9f418afb81c19 (patch)
tree97fe56077f553739a9c96915b76389f089a653e2 /setup.py
parent3db783dab2a1e72a436cd2d3f5131dbe7314c275 (diff)
downloadvirt-manager-49c2e046a1d68cbc8fc0263d2bb9f418afb81c19.tar.gz
Install before updating cache & compiling schemas
Closes #400
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7e47e7c7..6a546606 100755
--- a/setup.py
+++ b/setup.py
@@ -264,6 +264,8 @@ class my_install(setuptools.command.install.install):
setuptools.command.install.install.finalize_options(self)
def run(self):
+ setuptools.command.install.install.run(self)
+
if not self.distribution.no_update_icon_cache:
print("running gtk-update-icon-cache")
icon_path = os.path.join(self.install_data, "share/icons/hicolor")
@@ -275,8 +277,6 @@ class my_install(setuptools.command.install.install):
"share/glib-2.0/schemas")
self.spawn(["glib-compile-schemas", gschema_install])
- setuptools.command.install.install.run(self)
-
###################
# Custom commands #