summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2022-04-05 22:04:20 +0200
committerCole Robinson <crobinso@redhat.com>2022-04-13 08:35:40 -0400
commit46dc0616308a73d1ce3ccc6d716cf8bbcaac6474 (patch)
tree25b3d9cafe0fb871197b06621d3206e690b63ef0 /setup.py
parentc61074191d0d25ab7cd7830ef90a49a3caefcd09 (diff)
downloadvirt-manager-46dc0616308a73d1ce3ccc6d716cf8bbcaac6474.tar.gz
setup: add bits for setuptools-61
Quoting https://github.com/pypa/setuptools/issues/3227 "Setuptools >= 61, intentionally changes the way packages are built in the sensec that it will try to find files and fail if something is weird. Empty packages (like this one), are asked to explicitly add packages=[] to their configuration. This intentional change in behaviour is described in https://setuptools.pypa.io/en/latest/history.html#v61-0-0." Bug: https://bugs.gentoo.org/836645 Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index e95acd39..7e47e7c7 100755
--- a/setup.py
+++ b/setup.py
@@ -547,4 +547,5 @@ setuptools.setup(
},
distclass=VMMDistribution,
+ packages=[],
)