summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2020-07-11 18:46:33 -0400
committerCole Robinson <crobinso@redhat.com>2020-07-11 19:18:38 -0400
commit35bfdc26a652033556ce64b0ad8df5b0f4943c7c (patch)
treeb500f34213c40a2d2b5c1d23f4d0d3a5ce5e108d /setup.py
parent14f8d2ff7a7524992ba934dc1f1af71d39f8f5c3 (diff)
downloadvirt-manager-35bfdc26a652033556ce64b0ad8df5b0f4943c7c.tar.gz
setup: Use xgettext --add-comments=translators
So in the code we can prefix comments with 'translators:' before translated strings to have them show up in .pot file output Signed-off-by: Cole Robinson <crobinso@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9f84159a..06c2f50b 100755
--- a/setup.py
+++ b/setup.py
@@ -660,6 +660,7 @@ class ExtractMessages(distutils.core.Command):
potfile = "po/virt-manager.pot"
xgettext_args = [
"xgettext",
+ "--add-comments=translators",
"--msgid-bugs-address=" + bug_address,
"--package-name=virt-manager",
"--output=" + potfile,