summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCole Robinson <crobinso@redhat.com>2020-01-28 14:31:28 -0500
committerCole Robinson <crobinso@redhat.com>2020-01-28 14:31:28 -0500
commit01ccaf03be49c1c673858018a94f6c833b00c6a6 (patch)
tree2a56ead95012d8065f1eb3e768dd29ff9d7492af /setup.py
parentc3b4a713c108255a8146bf1cfd44e1ef2771948e (diff)
downloadvirt-manager-01ccaf03be49c1c673858018a94f6c833b00c6a6.tar.gz
setup: Run codespell on more files
And fix the results Signed-off-by: Cole Robinson <crobinso@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 13 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 9b91a0dc..9d130dc3 100755
--- a/setup.py
+++ b/setup.py
@@ -626,7 +626,16 @@ class CheckPylint(distutils.core.Command):
import pylint.lint
import pycodestyle
- files = ["setup.py", "virtinst", "virtManager", "tests"]
+ lintfiles = ["setup.py", "virtinst", "virtManager", "tests"]
+
+ spellfiles = lintfiles[:]
+ spellfiles += list(glob.glob("*.md"))
+ spellfiles += list(glob.glob("man/*.pod"))
+ spellfiles += ["data/virt-manager.appdata.xml.in",
+ "data/virt-manager.desktop.in",
+ "data/org.virt-manager.virt-manager.gschema.xml",
+ "virt-manager.spec.in"]
+ spellfiles.remove("NEWS.md")
try:
import codespell_lib
@@ -634,7 +643,7 @@ class CheckPylint(distutils.core.Command):
print("running codespell")
codespell_lib._codespell.main(
'-I', 'tests/data/codespell_dict.txt',
- '--skip', '*.pyc,*.iso,*.xml', *files)
+ '--skip', '*.pyc,*.iso,*.xml', *spellfiles)
except ImportError:
print("codespell is not installed. skipping...")
except Exception as e:
@@ -646,7 +655,7 @@ class CheckPylint(distutils.core.Command):
style_guide = pycodestyle.StyleGuide(
config_file='setup.cfg',
format="pylint",
- paths=files
+ paths=lintfiles,
)
report = style_guide.check_files()
if style_guide.options.count:
@@ -660,7 +669,7 @@ class CheckPylint(distutils.core.Command):
if self.jobs:
pylint_opts += ["--jobs=%d" % self.jobs]
- pylint.lint.Run(files + pylint_opts)
+ pylint.lint.Run(lintfiles + pylint_opts)
class VMMDistribution(distutils.dist.Distribution):