summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2023-04-13 10:46:45 +0200
committerRico Tzschichholz <ricotz@ubuntu.com>2023-04-13 10:47:48 +0200
commitcff2e6e470efae1f4e178ab13cb2b3d5dde502c3 (patch)
tree5c745da2cfce404e37d7f1668171baef8686d7d3 /tests/Makefile.am
parent0b2e7537e5575f1daabb37e93b5f74c78fd29eff (diff)
downloadvala-cff2e6e470efae1f4e178ab13cb2b3d5dde502c3.tar.gz
codegen: Fix usage of lambda-expression from delegate initializer
Unset delegate-type if a lambda-expression handler was found to use the correct code paths. Fixes https://gitlab.gnome.org/GNOME/vala/issues/1428
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index b7a46cb31..99cee6206 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -613,6 +613,7 @@ TESTS = \
objects/signals-generic-return.vala \
objects/signals-gobject-return.vala \
objects/signals-lambda-delegate.vala \
+ objects/signals-lambda-delegate-2.vala \
objects/signals-prototype-access.vala \
objects/signals-prototype-access-invalid.test \
objects/signals-prototype-access-invalid-2.test \