summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2010-08-05 10:17:48 +0200
committerJürg Billeter <j@bitron.ch>2010-08-05 21:20:04 +0200
commitabbcceab2fc3b674d1bb5d056f249c11cd5079a4 (patch)
tree90e6ecee787f5828fb669671dccbb8027c1321df /doc/Makefile.am
parent294b374af6e37cdac8ffb2b2db8fed72d323edb3 (diff)
downloadvala-abbcceab2fc3b674d1bb5d056f249c11cd5079a4.tar.gz
Add version suffix to installed files to allow parallel installation
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index d81c58b6b..71d979f47 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -22,3 +22,11 @@ EXTRA_DIST = \
vapigen.1 \
$(NULL)
+if ENABLE_UNVERSIONED
+install-data-hook:
+ cd $(DESTDIR)$(man1dir) && $(LN_S) -f valac@PACKAGE_SUFFIX@.1 valac.1
+if ENABLE_VAPIGEN
+ cd $(DESTDIR)$(man1dir) && $(LN_S) -f vala-gen-introspect@PACKAGE_SUFFIX@.1 vala-gen-introspect.1
+ cd $(DESTDIR)$(man1dir) && $(LN_S) -f vapigen@PACKAGE_SUFFIX@.1 vapigen.1
+endif
+endif