summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2018-02-20 22:50:24 +0100
committerRico Tzschichholz <ricotz@ubuntu.com>2018-02-20 22:50:24 +0100
commitf67582423a132e6c79b0b87c024bd6a8e370f2ad (patch)
treee095c9499ac5a84db91134c5d51146a2cddc8649 /configure.ac
parent80dcd7dd205a977c2570d5966cf1993416278d85 (diff)
downloadvala-f67582423a132e6c79b0b87c024bd6a8e370f2ad.tar.gz
tests: Add linux-specific test for feature test macros
https://bugzilla.gnome.org/show_bug.cgi?id=793444
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8acaf0394..662180b9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,19 @@ AC_PROG_LN_S
AC_PROG_INSTALL
AC_PROG_MKDIR_P
+AC_CANONICAL_HOST
+
+# Detect the target system
+build_linux=no
+case "${host_os}" in
+ linux*)
+ build_linux=yes
+ ;;
+ *)
+ ;;
+esac
+AM_CONDITIONAL([HAVE_LINUX], [test "$build_linux" = "yes"])
+
LT_PREREQ([2.2.6])
LT_INIT([disable-static])
PKG_PROG_PKG_CONFIG([0.21])