summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2019-04-02 12:31:58 +0200
committerRico Tzschichholz <ricotz@ubuntu.com>2019-04-02 17:24:36 +0200
commitecc4780ee90061aff810ebc551353ac2b346815c (patch)
tree91255857818760635494e10e45ad7c70984f2982 /configure.ac
parentddf82bd61b36e10c3c72ee2fd87d48f3a0f81f42 (diff)
downloadvala-ecc4780ee90061aff810ebc551353ac2b346815c.tar.gz
build: Require --with-cgraph configure flag when cross-compiling
Fixes https://gitlab.gnome.org/GNOME/vala/issues/775
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 408dfd86f..8de8b933b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -156,6 +156,7 @@ PKG_CHECK_MODULES(GMODULE, gmodule-2.0 >= $GLIB_REQUIRED)
AC_SUBST(GMODULE_CFLAGS)
AC_SUBST(GMODULE_LIBS)
+AC_ARG_WITH(cgraph, AS_HELP_STRING([--with-cgraph], [Required flag for cross-compilation to define capability of graphviz]), [], with_cgraph=check)
AC_ARG_ENABLE(valadoc, AS_HELP_STRING([--disable-valadoc], [Disable valadoc]), enable_valadoc=$enableval, enable_valadoc=yes)
if test x$enable_valadoc = xyes; then
PKG_CHECK_MODULES(LIBGVC, libgvc >= $LIBGVC_REQUIRED)
@@ -181,6 +182,17 @@ if test x$enable_valadoc = xyes; then
], [
AC_MSG_RESULT([no])
have_cgraph=no
+ ], [
+ if test x$with_cgraph = xcheck; then
+ AC_MSG_ERROR([--with-cgraph=yes/no is required for cross-compilation])
+ elif test x$with_cgraph = xyes; then
+ AC_MSG_RESULT([yes])
+ VALAFLAGS="$VALAFLAGS -D WITH_CGRAPH"
+ have_cgraph=yes
+ else
+ AC_MSG_RESULT([no])
+ have_cgraph=no
+ fi
]
)
LIBADD="$cgraph_tmp_LIBADD"