summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2022-02-12 12:58:22 +0100
committerRico Tzschichholz <ricotz@ubuntu.com>2022-02-12 15:04:32 +0100
commitbaebb4b5c41ecf4976cab6ca092c7998b06fb4c3 (patch)
tree76b73ad38e41d3c9b335ae4fd732d34b5adb0e08 /configure.ac
parent7e75f8126b00f3549d8c421559270508d39db0ed (diff)
downloadvala-baebb4b5c41ecf4976cab6ca092c7998b06fb4c3.tar.gz
tests: Add more Werror=... flags
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cd036c78e..e598b927e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,13 +126,19 @@ TEST_EXTRA_CFLAGS="-Werror=init-self \
-Werror=return-type \
-Werror=sequence-point \
-Werror=uninitialized \
+-Werror=init-self \
+-Werror=int-in-bool-context \
-Werror=int-to-pointer-cast \
-Werror=pointer-to-int-cast \
-Werror=compare-distinct-pointer-types \
-Werror=empty-body \
+-Werror=comment \
+-Werror=strict-overflow \
-Wformat=2 \
-Werror=format-security \
-Werror=format-nonliteral \
+-Werror=format-overflow=2 \
+-Werror=format-truncation=2 \
-Werror=int-conversion \
-Werror=duplicated-branches \
-Werror=duplicated-cond \
@@ -142,9 +148,12 @@ TEST_EXTRA_CFLAGS="-Werror=init-self \
-Werror=missing-declarations \
-Werror=missing-prototypes \
-Werror=strict-prototypes \
+-Werror=bool-compare \
-Werror=tautological-pointer-compare \
+-Werror=logical-not-parentheses \
-Werror=address \
-Werror=array-bounds \
+-Werror=array-parameter=2 \
-Werror=enum-conversion"
TEST_CFLAGS=