summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2018-01-06 21:02:35 +0100
committerRico Tzschichholz <ricotz@ubuntu.com>2018-08-09 20:25:00 +0200
commit99d1fd0a4846e755fae011822e2ced29630df997 (patch)
tree32258d20acda93eb8dba19e9204fe5827b6af4aa /configure.ac
parent10f72d4fa6dbfcadf0ac97ce96ed3443077e584f (diff)
downloadvala-99d1fd0a4846e755fae011822e2ced29630df997.tar.gz
vala: Add consts/methods to retrieve and check library version
https://gitlab.gnome.org/GNOME/vala/issues/304
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cc02d2863..366f52d54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,13 @@ AM_MAINTAINER_MODE([enable])
API_VERSION=0.42
PACKAGE_SUFFIX="-$API_VERSION"
+VALA_MAJOR_VERSION=`echo $PACKAGE_VERSION | cut -d. -f1 | sed s/[a-zA-Z\-].*//g`
+VALA_MINOR_VERSION=`echo $PACKAGE_VERSION | cut -d. -f2 | sed s/[a-zA-Z\-].*//g`
+VALA_MICRO_VERSION=`echo $PACKAGE_VERSION | cut -d. -f3 | sed s/[a-zA-Z\-].*//g`
+AC_SUBST(VALA_MAJOR_VERSION)
+AC_SUBST(VALA_MINOR_VERSION)
+AC_SUBST(VALA_MICRO_VERSION)
+
dnl http://people.gnome.org/~walters/docs/build-api.txt
dnl We don't support separate builddir when building from git
echo \#buildapi-variable-no-builddir >/dev/null