summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2020-07-11 18:29:42 +0200
committerRico Tzschichholz <ricotz@ubuntu.com>2020-07-11 18:29:42 +0200
commit1e4228e3e1ff6240ca1865b589dcf446af4dfa3c (patch)
tree5384100578103fd573ae6cfb422f214c6a9ea0ba /configure.ac
parent8f9f2f1dd29de5e2b4462c18c7f397038fce0025 (diff)
downloadvala-1e4228e3e1ff6240ca1865b589dcf446af4dfa3c.tar.gz
testrunner: Add more -Werror=* flags
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ee52f0440..87dbf8cfd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,7 @@ AC_SUBST(COVERAGE_LIBS)
# Check supported compiler flags used in testrunner.sh
TEST_EXTRA_CFLAGS="-Werror=init-self \
-Werror=implicit \
+-Werror=implicit-fallthrough \
-Werror=pointer-arith \
-Werror=redundant-decls \
-Werror=return-type \
@@ -126,6 +127,7 @@ TEST_EXTRA_CFLAGS="-Werror=init-self \
-Werror=int-to-pointer-cast \
-Werror=pointer-to-int-cast \
-Werror=compare-distinct-pointer-types \
+-Werror=empty-body \
-Wformat=2 \
-Werror=format-security \
-Werror=format-nonliteral \
@@ -134,8 +136,11 @@ TEST_EXTRA_CFLAGS="-Werror=init-self \
-Werror=duplicated-cond \
-Werror=declaration-after-statement \
-Werror=maybe-uninitialized \
+-Werror=missing-braces \
+-Werror=missing-declarations \
-Werror=missing-prototypes \
-Werror=strict-prototypes \
+-Werror=address \
-Werror=array-bounds \
-Werror=enum-conversion"