summaryrefslogtreecommitdiff
path: root/compiler/Makefile.am
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2010-06-30 23:49:59 +0200
committerJürg Billeter <j@bitron.ch>2010-06-30 23:49:59 +0200
commitce27f41ee5f37a2baa90ad3f0057346c1eaac4ad (patch)
treeb21573941a562191bfd4ea2c45718ab8158db2af /compiler/Makefile.am
parent1e8d9aea367d12b4943da474306c25aa62d23f70 (diff)
downloadvala-ce27f41ee5f37a2baa90ad3f0057346c1eaac4ad.tar.gz
Add experimental vala tool for use with #!
Diffstat (limited to 'compiler/Makefile.am')
-rw-r--r--compiler/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/compiler/Makefile.am b/compiler/Makefile.am
index e4763b3d8..bbc933580 100644
--- a/compiler/Makefile.am
+++ b/compiler/Makefile.am
@@ -37,6 +37,9 @@ valac_LDADD = \
EXTRA_DIST = $(valac_VALASOURCES) valac.vala.stamp
+install-exec-hook:
+ cd $(DESTDIR)$(bindir) && $(LN_S) -f valac$(EXEEXT) vala$(EXEEXT)
+
MAINTAINERCLEANFILES = \
$(valac_VALASOURCES:.vala=.c) \
$(NULL)