summaryrefslogtreecommitdiff
path: root/compiler/Makefile.am
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2009-04-14 17:16:20 +0200
committerJürg Billeter <j@bitron.ch>2009-04-14 17:16:20 +0200
commit8faaee83186459e0a77e33342f9a8011c39fa49b (patch)
tree9e94c1a741a1e91cf56c8373c8a74ec2d6f2fc74 /compiler/Makefile.am
parente9a1c3c5d60c35692785270655dd3b598b2a68d1 (diff)
downloadvala-8faaee83186459e0a77e33342f9a8011c39fa49b.tar.gz
Remove generated .c files on make maintainer-clean
Fixes bug 509146.
Diffstat (limited to 'compiler/Makefile.am')
-rw-r--r--compiler/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/compiler/Makefile.am b/compiler/Makefile.am
index a92823128..a50bd40cc 100644
--- a/compiler/Makefile.am
+++ b/compiler/Makefile.am
@@ -35,3 +35,8 @@ valac_LDADD = \
$(NULL)
EXTRA_DIST = $(valac_VALASOURCES) valac.vala.stamp
+
+MAINTAINERCLEANFILES = \
+ $(valac_VALASOURCES:.vala=.c) \
+ $(NULL)
+