summaryrefslogtreecommitdiff
path: root/compiler/Makefile.am
diff options
context:
space:
mode:
authorJürg Billeter <j@bitron.ch>2009-09-26 21:58:39 +0200
committerJürg Billeter <j@bitron.ch>2009-09-26 23:19:36 +0200
commit331d4e8d2927eb912edd9b286568376149f60322 (patch)
tree48b7faf0bb769bdbde36318eea87caacc4a6c68b /compiler/Makefile.am
parent4d4176547022421e24fda56041862bdf129dbd3c (diff)
downloadvala-331d4e8d2927eb912edd9b286568376149f60322.tar.gz
Add support for coverage analysis using gcov and lcov
Diffstat (limited to 'compiler/Makefile.am')
-rw-r--r--compiler/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/compiler/Makefile.am b/compiler/Makefile.am
index 4cbe5ba2c..45e4fd760 100644
--- a/compiler/Makefile.am
+++ b/compiler/Makefile.am
@@ -1,6 +1,7 @@
NULL =
AM_CPPFLAGS = \
+ $(COVERAGE_CFLAGS) \
-I$(top_srcdir)/gee \
-I$(top_srcdir)/ccode \
-I$(top_srcdir)/vala \
@@ -26,10 +27,11 @@ valac_SOURCES = \
$(NULL)
valac.vala.stamp: $(valac_VALASOURCES)
- $(VALAC) $(VALAFLAGS) -C --vapidir $(srcdir)/../vapi --pkg gobject-2.0 --vapidir ../gee --pkg gee --vapidir ../ccode --pkg ccode --vapidir ../vala --pkg vala --vapidir ../codegen --pkg codegen --pkg config $^
+ $(VALAC) $(COVERAGE_VALAFLAGS) $(VALAFLAGS) -C --vapidir $(srcdir)/../vapi --pkg gobject-2.0 --vapidir ../gee --pkg gee --vapidir ../ccode --pkg ccode --vapidir ../vala --pkg vala --vapidir ../codegen --pkg codegen --pkg config $^
touch $@
valac_LDADD = \
+ $(COVERAGE_LIBS) \
$(GLIB_LIBS) \
../codegen/libvala.la \
$(NULL)