summaryrefslogtreecommitdiff
path: root/ccode/Makefile.am
diff options
context:
space:
mode:
authorRico Tzschichholz <ricotz@ubuntu.com>2022-12-14 17:22:44 +0100
committerRico Tzschichholz <ricotz@ubuntu.com>2022-12-22 17:00:29 +0100
commita67d19f51082944e3751760d6c0ae09efc35b860 (patch)
tree1c6ad3be7cfbff441d290f572b65f38ff339dd78 /ccode/Makefile.am
parent144566870cb7263ba7827459bf2ec2a9aa86e193 (diff)
downloadvala-a67d19f51082944e3751760d6c0ae09efc35b860.tar.gz
codegen: Use a special CCodeBinaryExpression for string comparisons
This preserves support for recursive replacement of arguments while this expression was actually transformed into a function call.
Diffstat (limited to 'ccode/Makefile.am')
-rw-r--r--ccode/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/ccode/Makefile.am b/ccode/Makefile.am
index c87c5dd1d..f0062efe2 100644
--- a/ccode/Makefile.am
+++ b/ccode/Makefile.am
@@ -20,6 +20,7 @@ libvalaccode_la_VALASOURCES = \
valaccode.vala \
valaccodeassignment.vala \
valaccodebinaryexpression.vala \
+ valaccodebinarycompareexpression.vala \
valaccodeblock.vala \
valaccodebreakstatement.vala \
valaccodecasestatement.vala \